Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PrintOpen returns -1

2 posts in General Discussion Last posting was on 2013-03-06 15:52:25.0Z
Donato Posted on 2013-03-06 15:19:23.0Z
Sender: 7f43.51375b57.1804289383@sybase.com
From: Donato
Newsgroups: sybase.public.powerbuilder.general
Subject: PrintOpen returns -1
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <51375e7b.7fe2.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 6 Mar 2013 07:19:23 -0800
X-Trace: forums-1-dub 1362583163 172.20.134.41 (6 Mar 2013 07:19:23 -0800)
X-Original-Trace: 6 Mar 2013 07:19:23 -0800, 172.20.134.41
Lines: 19
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:249829
Article PK: 1308166

Why PrintOpen returns -1?
My PB enviroment is: 12.5.1 build 4953 on windows 7 or XP.

PrintOpen works fine only if I compile the application and
run myapp.exe and with only the following script:

ulong ll_job //if you define long, not works????
ll_job = PrintOpen("type here any things", TRUE)
PrintDataWindow(ll_job, dw_report)
PrintClose(ll_job)

???

This error is not present on PB 12.5.1 build 4541.

please help me.

TIA
Donato


Chris Pollach Posted on 2013-03-06 15:52:25.0Z
From: Chris Pollach <cpollach@travel-net.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20130215 Thunderbird/17.0.3
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.general
Subject: Re: PrintOpen returns -1
References: <51375e7b.7fe2.1681692777@sybase.com>
In-Reply-To: <51375e7b.7fe2.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <51376639$1@forums-1-dub>
Date: 6 Mar 2013 07:52:25 -0800
X-Trace: forums-1-dub 1362585145 172.20.134.152 (6 Mar 2013 07:52:25 -0800)
X-Original-Trace: 6 Mar 2013 07:52:25 -0800, vip152.sybase.com
Lines: 46
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:249830
Article PK: 1308164

Hi Donato;

Please be careful with EBF's as they are *not* fully system tested
and my cause other bugs and/or regression problems!

FWIW: I would only use proper MR (Maintenance Release) versions of
PB that are *fully* system tested. The last MR for 12.5.1 is build 4015.

--

Regards ... Chris
President: OSUG / STD Inc.
Vice President: ISUG-TECH
Blog: http://chrispollach.blogspot.com
SourceForge: http://sourceforge.net/projects/stdfndclass
PBDJ: http://chrispollach.sys-con.com
TKD: http://www.syeoh.com

On 3/6/2013 10:19 AM, Donato wrote:
> Why PrintOpen returns -1?
> My PB enviroment is: 12.5.1 build 4953 on windows 7 or XP.
>
> PrintOpen works fine only if I compile the application and
> run myapp.exe and with only the following script:
>
> ulong ll_job //if you define long, not works????
> ll_job = PrintOpen("type here any things", TRUE)
> PrintDataWindow(ll_job, dw_report)
> PrintClose(ll_job)
>
> ???
>
> This error is not present on PB 12.5.1 build 4541.
>
> please help me.
>
> TIA
> Donato
>