Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PB 12.5 startup

3 posts in General Discussion Last posting was on 2013-03-01 16:24:49.0Z
Eric Posted on 2013-03-01 10:37:15.0Z
From: Eric <pigexpert@agrisyst.com>
User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20130215 Thunderbird/17.0.3
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.general
Subject: PB 12.5 startup
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <513084db$1@forums-1-dub>
Date: 1 Mar 2013 02:37:15 -0800
X-Trace: forums-1-dub 1362134235 172.20.134.152 (1 Mar 2013 02:37:15 -0800)
X-Original-Trace: 1 Mar 2013 02:37:15 -0800, vip152.sybase.com
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:249761
Article PK: 1308021

We received a dll written in c#. There is a complete description how to
use the dll's. Its all c# code.

I suppose the best way to use these dll's is in Powerbuilder .Net 12.5
Till now we have only used PB 12.5 Classic. I checked the versions and
both are 12.5.1.4541.

If we start PB .Net we get the message (translated from dutch).

c:\program files\syabse\powerbuilder 12.5\pbshell.exe
The application can not start because the configuration next to each
other is not correct. Use the commandline sxstrace.exe for more information.

What can we do to get it started

Thanks
Eric


Chris Pollach Posted on 2013-03-01 12:57:16.0Z
From: Chris Pollach <cpollach@travel-net.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20130215 Thunderbird/17.0.3
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.general
Subject: Re: PB 12.5 startup
References: <513084db$1@forums-1-dub>
In-Reply-To: <513084db$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <5130a5ac$1@forums-1-dub>
Date: 1 Mar 2013 04:57:16 -0800
X-Trace: forums-1-dub 1362142636 172.20.134.152 (1 Mar 2013 04:57:16 -0800)
X-Original-Trace: 1 Mar 2013 04:57:16 -0800, vip152.sybase.com
Lines: 47
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:249764
Article PK: 1308024

Hi Eric;

PB.Net depends on the VS "Isolated Shell" and the .Net 4.0 run-time
being installed correctly. I wonder if one of these is not present or
improperly installed?

You might want to uninstall and then re-install PB.net. It usually
detects the presence or absence of its dependent software counter-parts
and asks you if its OK to install them.

HTH

--

Regards ... Chris
President: OSUG / STD Inc.
Vice President: ISUG-TECH
Blog: http://chrispollach.blogspot.com
SourceForge: http://sourceforge.net/projects/stdfndclass
PBDJ: http://chrispollach.sys-con.com
TKD: http://www.syeoh.com

On 3/1/2013 5:37 AM, Eric wrote:
> We received a dll written in c#. There is a complete description how to
> use the dll's. Its all c# code.
>
> I suppose the best way to use these dll's is in Powerbuilder .Net 12.5
> Till now we have only used PB 12.5 Classic. I checked the versions and
> both are 12.5.1.4541.
>
> If we start PB .Net we get the message (translated from dutch).
>
> c:\program files\syabse\powerbuilder 12.5\pbshell.exe
> The application can not start because the configuration next to each
> other is not correct. Use the commandline sxstrace.exe for more
> information.
>
> What can we do to get it started
>
> Thanks
> Eric


Bruce Armstrong Posted on 2013-03-01 16:24:49.0Z
User-Agent: NewsTap/4.0.1 (iPad)
From: Bruce Armstrong <NOCANSPAM_bruce.armstrong@yahoo.com>
Newsgroups: sybase.public.powerbuilder.general
Content-Type: text/plain; charset=UTF-8
Mime-Version: 1.0
Content-Transfer-Encoding: 8bit
Message-ID: <1964864785383847959.267281NOCANSPAM_bruce.armstrong-yahoo.com@forums.sybase.com>
Subject: Re: PB 12.5 startup
References: <513084db$1@forums-1-dub>
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 1 Mar 2013 08:24:49 -0800
X-Trace: forums-1-dub 1362155089 172.20.134.152 (1 Mar 2013 08:24:49 -0800)
X-Original-Trace: 1 Mar 2013 08:24:49 -0800, vip152.sybase.com
Lines: 31
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:249769
Article PK: 1308032

You don't have to user PowerBuilder.Net to use .Net assemblies. If the
assembly is COM visible you could use it from a PowerBuilder Classic Win32
target using a COM Callable Wrapper. You could also call it from a
conditional code block in a WinForm or other .Net target in PowerBuilder
Classic.

It's easier to use .Net assemblies from PowerBuilder.Net, but it's not the
only option.

Eric <pigexpert@agrisyst.com> wrote:
> We received a dll written in c#. There is a complete description how to
> use the dll's. Its all c# code.
>
> I suppose the best way to use these dll's is in Powerbuilder .Net 12.5
> Till now we have only used PB 12.5 Classic. I checked the versions and
> both are 12.5.1.4541.
>
> If we start PB .Net we get the message (translated from dutch).
>
> c:\program files\syabse\powerbuilder 12.5\pbshell.exe
> The application can not start because the configuration next to each
> other is not correct. Use the commandline sxstrace.exe for more information.
>
> What can we do to get it started
>
> Thanks
> Eric

--
PowerBuilder Developer Center Forums - http://goo.gl/VXpIb